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The Playlists User Interface 
OnTheAir Video Express 3 is a very intuitive program with a lot of features and 
functions. What follows is a brief overview of each of the features beginning with an 
overview of the User Interface.  We will start with the UI with which OnTheAir Video 
Express opens, and then will go through each feature of the Menu, tab by tab and 
line by line.

Each feature of the above UI is described briefly hereafter:
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This is the Title Bar of the playlist currently being played, and it shows the 
name of the playlist, as well as which output is being used for the playlist.

You can change the title by clicking on the ⌄; 
this will open a popup that allows you to select the title, any tags associated 
with the file, and the location of the file.

This bar shows the timecode for the playing clip: 

The larger number on the left shows how long the clip has been playing 
(elapsed time), while the one on the right shows how much time remains on 
the clip.  

Note that by right-clicking on either of those time 
information you can change them to read the playing 
time / time remaining on the playlist as a whole, rather 
than just the clip in play.  

Between those timecodes are two bars: a red bar on top of a blue bar.  
•  The blue bar shows the progression of the clip, 
•  The red bar shows the progression of the playlist.  

Double-clicking on the blue bar opens the scrubbing line, and by clicking at 
any point on the line you may move the clip to that point.  Above the bars are 
two smaller timecodes; the one on the left shows the current playtime of the 
clip that is in play, while the timecode on the right shows the entire duration of 
the playlist.  Below the bars is the title of the clip currently in play.
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Playback Controls 

The Playback Controls will be familiar to most everyone.  They are, from 
left to right: Play Previous Clip; Stop Clip; Pause Clip; Skip to Next Clip; 
and Lock.  Clicking on the Lock button grays out most of the functions on 
the UI, preventing anyone from inadvertently clicking on a button while the 
playlist is playing out, potentially disrupting the playout.  Clicking again on 
the Lock button unlocks the functions.

Playlist Settings 

To the right of the Playback Controls is the Detail Level panel, and these 

controls allow you to select how much detail is displayed about the clips in 
the playlist.  There are three levels of detail that may be selected. The 
lowest level shows only three things about the clip: how much time into the 
playlist the clip will start; the clip’s title; and the duration of the clip.  The 
second level of detail shows the above information, and also shows a still 
shot from each clip.  The third level (see below) displays the above 
information, plus the video format of the file and the date and time that the 
clip was created.

To the right of the Detail Level panel are the four Options buttons: 

Chain, Loop, Cue, and Key; each option is explained below.  Note: by right 

clicking on any of the options you may assign or clear a MIDI note to enable 
the feature.
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The Chain button sets the playlist to automatically play each clip in 
succession.

The Loop button causes the clip to reply after it finishes playing.  If the 
Chain button and the Loop button are both in use, the clips will play in 
order, and the playlist will replay from the beginning upon the completion of 
the final clip.

The Cue button puts OnTheAir Video Express into Cue Mode.  While in 
Cue Mode, each clip will stop on the last frame. The user will then have to 
click the Play button (or hit the space bar) to go the next clip, where it will 
pause on the first frame.  Clicking Play again (or pushing the space bar) will 
start the clip.  Note that the Cue Mode cannot be enabled while the Chain or 
Loop functions are enabled.

The Key button enables Key mode if you have a video card connected that 
supports keying.

Contextual Menu in the Playlist 

Below the Playback Controls, Detail Levels, and Options is the Playlist 
Queue.  You can drag clips into the playlist or open a previously constructed 
playlist.  See Creating a Playlist with OnTheAir Video Express for more 
information.  

Right-clicking on a clip opens a popup with a number of options for that clip: 
Set Attributes…; Set In Out Point…; Reveal in Finder; Replace…; 
Assign MIDI Note…; Clear MIDI Note; and Configure MIDI Output 
Note…

The function of each option is described briefly:
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Set Attributes…: This feature brings up the Clip Inspector for the 
highlighted file, and is open to the Attributes tab.  For more information, see 
The Window Menu: Clip Inspector.

Set In Out Point…: This brings up the Clip Inspector as well, open to the 
Timeline tab.  For more information see The Window Menu: Clip 
Inspector.

Reveal in Finder: This opens the Finder window, showcasing the selected 
clip in its Folder.

Replace: This opens the Finder window as well, listing the files in your 
selected Media Folder.  From there you can click on a file you would like to 
use in place of the highlighted clip in the playlist; clicking the Open button 
replaces the original clip.

Assign MIDI Note…: This allows you to assign a MIDI note to control the 
clip.

Clear MIDI Note…: This clears the MIDI note previously assigned.

Configure MIDI Output Note:  This allows you to set the Channel and Note 
for use with MIDI.

Below the Playlist Queue at the bottom left of the OnTheAir Video Express 
window is the Playlist Timecode.  It shows the total duration of the playlist, 
and in parentheses next to the timecode the number of clips in the playlist.

Below the Playlist Queue at the bottom right of the OnTheAir Video 
Express window is the Selection Timecode.  This shows the duration of all 
selected (highlighted) clips, and in parentheses the number of selected 
clips.
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Clip Inspector 

By highlighting a clip on your playlist and opening Clip Inspector, you open 
some useful functions and information available for that clip.  There are four 
tabs within the Clip Inspector: Attributes, Timeline, Metadata, and Info.

Attributes: This panel reveals important information about the clip in play, 
and allows you to change some of its attributes.  

At the top of the panel will be shown the title of the clip.  Immediately below 
that is the Clip End Behaviour. The default is Normal, and the clip will end 
as per the indicated in the playlist’s Options.  The behavior may be modified 
to any of the following options: Stop at End, Hold Last Frame, Play Next 
Clip, and Loop.

Below the Clip End Behaviour is the Resize Mode.  Your options are Fill, 
Pan & Scan, and Letterbox.

Below that is a box that, if checked, Reverses the Field Order, and below 
that is a sliding bar with which you may adjust the clip’s Audio Gain.
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The next tab is the Timeline Tab, which will show a large still shot of the 
playing clip.  

Above and to the left of the still shot is a time clock showing the current 
position of the still shot within the clip; you can move forward or backward 
into the clip via a sliding bar beneath the still; you may also hit the play 
button to play the clip.  Above and to the right of the still is the total duration 
of the clip.

Below the sliding bar is a box labeled “In Point” wherein the starting point of 
the clip is indicated (typically 00:00:00 unless modified).  To the right of that 
is another box,, titled “Media Duration,” showing the duration of the clip.  To 
the right of that is the End Point box, showing at what point in the clip the 
video ends (typically the time of the last frame of the clip, unless modified).  
The In-Point and Out-Point time clocks can modified, thus changing the 
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starting time within the clip and/ or the ending time within the clip; when 
either of the these attributes is changed, the Media Duration changes to 
match the current duration of the clip.  Below the In Point and Out Point 
boxes are three buttons: Mark, Go, and Clear.  Mark saves the In/ Out 
Point, Go sends the clip to the position of the In/ Out Point, and Clear resets 
the In/ Out Points to the original times.

The Metadata tab shows some metadata inherent to the clip.

The Info tab shows some important information about the clip, such as its 
source, size, format, and so on.
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A Tour of the various Menus 

The “OnTheAir Video Express” Menu 

Clicking on the OnTheAir Video Express tab on the menu bar brings up a list 
of eight options, discussed below: 

About OnTheAir Video Express…: This brings up some basic information 
about OnTheAir Video Express, including the version number, license 
information, and copyright information (see left).  
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The Preferences 
Preferences…: Clicking on this opens up the Preferences panel:  

Defaults:  Clicking this opens the Defaults panel, which allows you to set 
defaults for your OnTheAir playlists and clips.  This will not affect anything in 
the current playlist, but rather anything dragged into the playlist from another 
folder.  The options are:

•  Chain by default:  With this box enabled, newly added clips will be 
in Chain mode.

•  Loop by default:  When this box is enabled, newly added clips will 
be in Loop mode.

•  Cue by default:  When this box is enabled, newly added clips will 
be in Cue mode.

•  Auto-update start times: This feature is not Available in OnTheAir 
Video Express

• Color text with Finder tag color: When enabled, each clip 
dragged to the playlist will be displayed in the color of the Finder 
tag.

• Resize Mode: Here you can select from three resize modes: Fill; 
Pan & Scan; and Letterbox. 

• Clip End Behaviour: Here you can set what happens at the end of 
a clip dragged into the playlist. If Normal is selected, the playlist will 
continue as before.  If Stop at End, the clip will stop when it finishes 
playing.  If Hold Last Frame, the clip will stop at the end and hold in 
its last frame.  If Play Next Clip is selected, the next clip will play 
immediately after the added clip finishes.  If Loop is selected, the 
clip will replay when it finishes playing.

• Still images default duration:  Here you can set the duration for 
still images on the playlist.
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• Offline clips default duration: Here you can se the duration for 

offline clips played on the playlist.

Playback:  Clicking this opens the Playback panel, which allows you to set 
up your Player Settings.  Any changes made to the Playback Preferences 
must be saved by clicking the Apply button on the bottom right hand corner 
of the panel.

The first option shown is to Enable SMART Resize and Graphics.  This is 
not available for OnTheAir Video Express, only in OnTheAir Video.

The Release button allows other users to utilize the graphics card even as 
you use OnTheAir Video Express.

Other options include:
• Video Device Output: This allows you to select any available video 

outputs to play and/ or record your playlist.
• Video Format: From here you may select the format you would like to 

play out your clips.  The list is quite extensive (40 different formats), 
ranging from SD to 4k.

• Pixel Format: You may choose either YUV 8 bits or ARGB as your 
Pixel Format.

• Audio Channels: You may select 2, 8, or 16 audio channels.
• Sample Size: Your Sample Size may be either 16 or 32 bits per 

package.
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GPI: The GPI Preference allows you to use a GPICommander to control 
OnTheAir Video Express.  

You must first select the GPICommander to use, and then you can set up 
your GPICommander to execute the following commands by setting the 
command to whichever input you desire: Cue Selected Clip; Play Selected 
Clip; Re-Cue Current Clip; Re-Play Current Clip; Cue Next Clip; Space 
Bar; Stop; Pause; Release Pause; Play Next Clip; Select Next Clip; 
Select Previous Clip.  You can select the following Output Actions by 
setting them to an output on your GPICommander: Playing; Paused/ Cued.  
If the “Send to all open documents” box is checked, each GPI command will 
be sent to every open document.

ATEM: This tab allows you to use an ATEM switcher to trigger playback on 
OnTheAir Video Express.  

To do so you must check the box next to “Use an ATEM switcher to trigger 
playback,” then input the ATEM Swicther IP Address and select the 
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OnTheAir Video Express Input. Enabling the box at the bottom of the panel 
allows you to cue the next clip in the playlist when you deselect the 
OnTheAir Video Express Input.

Logs: The Logs tab allows you to choose the folders you would like to use 
to keep your Technical Logs and As-Run Logs.  

You may type the path in the relevant box or you may use the Select… 
buttons to set up the path.  You may also set up how much information the 
technical logs gather.  There are four different levels of information, from 
least comprehensive to most comprehensive: Critical, Warning, Info (the 
default level), and Debug.  If you change the default paths, make sure you 
are able to locate them if needed for troubleshooting!
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Licenses Window 

Licenses…: This pulls up the registration and activation panel.  

It will display the serial numbers and description (including the version 
number and options enabled) of the installed OnTheAir Video Express 
software, and if the serial number is activated a ✔ will be displayed to the 

left of the number.  

Directly below the serial number box are two buttons: Add Serial Number… 
and Clear All Serial Numbers.  Clicking the Add Serial Number… button 
opens a box wherein you may type in (or cut and paste) a purchased serial 
number.  

The Clear All Serial Numbers button allows you to clear all expired serial 
numbers from your system — recommended before you add new serial 
numbers, to prevent potential conflicts when your computer is searching for 
active numbers.

Once a serial number is entered, it must then be activated.  If the computer 
is connected to the internet you may click on the “Activate via internet” 
button. 

To deactivate a serial number you would click on the “Deactivate via 
internet button” to the right.  You must deactivate your license BEFORE 
doing any of the following:

www.softron.tv - For our Facebook, Twitter, Skype or YouTube pages, search for: SoftronMedia

http://www.softron.tv


User Manual
• you move your disk from one computer to another
• you have made a clone of your hard drive and you want to start from the 

cloned hard drive
• you reformat your drive and reinstall it
• you upgrade your system OS (for example from 10.6.x to 10.7.x)
• you delete or modify the file (example for OnTheAir Video Express) : /

Library/Application Support/Softron/OnTheAir Video Express System ID

If your computer is not connected to the internet, you may activate or 
deactivate your serial number manually by clicking on the appropriate button 
near the bottom of he panel.

There is also a button at the bottom left of the panel that will take you to the 
Softron website, where you may purchase a new serial number.  

At the bottom right of the panel is the Close button, which will close the 
Licenses… panel.

Services is an OS feature, so we will not go into it.

Hide OnTheAir Video Express sends the application into the background.

Hide Others sends all other software operations except OnTheAir Video 
Express to the background.

Quit OnTheAir Video Express shuts down the application.  

The “File” Menu 

New Playlist: This opens a new panel to create a new playlist.  The easiest 
way to create a playlist is to pull the desired clips into the playlist panel from 
a media file.
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Open Playlist: This allows you to open a playlist you have already set up.

Open Recent Playlist: This allows you to select and open a playlist you 
have recently used.

Add Media Files:  This allows you to add a media file to an open playlist.

Add Offline Clip: This allows you to add an offline clip to an open playlist.

Check for Missing Clips: This allows you to search for a clip that was 
moved from the playlist folder.

Close Playlist:  This closes an open playlist.

Save:  This saves any changes made to an open playlist.

Duplicate:  This creates a copy of an open playlist.

Rename…: This allows you to rename an open playlist.

Move To…: This allows you to move an open playlist to another folder.

Revert To…: This allows you to change a playlist back to a prior set up.

The “Edit” Menu 
For the most part, the Edit Tab in OnTheAir Video Express functions as it 
does in word processing software, though the commands apply to whole 
clips.  You may, therefore, Cut or Copy a clip from a Playlist and then Paste 
it to another Playlist.  You can Undo or Redo a command, or Select All of 
the clips to issue them all a command.  A couple of the commands, though, 
are specific to OnTheAir Video Express:
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Now Playing: This displays the currently playing clip, useful when the 
playlist contains a lot of clips.

The “Window” Menu 

Show Clip Inspector: This pulls up the Clip Inspector Window.  Clip 
Inspector is given more detail below.

Show Log Window: This pulls up the Log, which features six gauges that 
show different performance indicators on your Mac.  At the bottom left 
corner of the window is a box that if checked brings up the Log automatically 
if an error occurs; unchecking the box requires you to manually pull up the 
Log if you so desire.  

The gauges are shown in one of three colors: green (everything looks 
good!), orange (warning: performance is less than ideal), and red (danger: 
your system is severely over-worked).  

Reading: This gauge displays the average time it takes to read from the 
storage device.

Rendering: This displays the average time it takes to render the video 
frames (including overlays and resize)
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Sys. Memory: This displays the global memory usage of the machine

Decomp.: This displays the average time it takes to decompress a video.

Output: This displays the average time it takes to out put the video/ audio to 
the output device.

Buffers: This displays the memory buffer usage.

Show Time Information: This function shows timecode information, either 
from the clip in play, the current playlist, or the current internal Mac clock.  It 
also displays the title of the current clip and the title of the next clip. 

The default setting is to the Clip Remaining Time, which shows the time 
left in the current clip.  The other options include the Clip Position Time, 
showing the current position time in the clip; Playlist Remaining Time, 
which shows how much time is left in the playlist; Playlist Elapsed Time, 
which shows how much time has progressed in the playlist; and Local 
Internal Mac Clock, which shows the current time according to the Mac’s 
Internal clock.

At the bottom of the Windows Tab the currently playing playlist will be 
displayed.

The “Help” Menu:
The Help menu provides the means to seek assistance with OnTheAir 
Video Express.  
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The Search box allows you to search MacHelp, and also allows you to 
search for and open a menu item (for example, typing “Schedule” would 
open the window on the right.

Search Knowledge Base opens Softron’s extensive Knowledge Base web 
site to help troubleshoot any issues or questions you may have regarding 
our products.

Contact Softron Support… opens a window that allows you to gather logs 
and open a support ticket if you are encountering a situation that you were 
unable to solve by means of our Knowledge Base web site.  
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