
OnTheAir CG Manual               

OnTheAir CG is composed of two different applications:   

• OnTheAir CG Designer is used to create projects, and can only play one 
project at a time. 

• OnTheAir CG Server plays out projects, and can play out multiple projects at a 
time. This is the one that is controlled by OnTheAir Video or OnTheAir Node. 

While either application can output to a video device, only the one with the license 
activated will output without a blue demo watermark. It is recommended that you 
activate your license on the OnTheAir CG Server application, and use the OnTheAir 
CG Designer in "DEMO" mode. Even with OnTheAir CG Designer in DEMO mode, 
there are no limitations on the number of projects you create, and you may preview 
them in the user interface.  OnTheAir CG Server will then be used to play out the 
projects. 

The manual will be divided in 2 sections:  
• Part I for OnTheAir CG Designer  
• Part II for OnTheAir CG Server. 
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First Things First 
Before we get into the ins and outs of your OnTheAir CG application, and how to 
utilize its many features, you must first register your application (though when 
downloaded as a DEMO version, the application is fully functional, albeit with 
occasional watermark displayed in the playout). 

When you register your license, it is important to remember that a single license may 
only be used for OnTheAir CG Designer OR OnTheAir CG Server at the same time.  
Most users opt to reserve the license for OnTheAir CG Server, leaving OnTheAir CG 
Designer in DEMO mode.  While in DEMO mode, projects may still be created and 
modified without any interference.   

Click here to view our on-line white pages article on HOW TO activate your serial 
number. 

As well, if at any time you encounter a technical issue while using your OnTheAir CG 
application, please open a Support Ticket by clicking on Help > Contact Softron 
Support.  You will be directed to gather logs, select the date of the issue, and to offer 
a brief description of the issue.  Please indicate the Date and Time of the incident in 
the description (as the logs can be very long), and, if possible attach screen shots (or 
screen recordings).  The more information you can provide, the more expeditiously 
we will be able to offer a solution.  And remember: during the life of your Softron 
application we offer support at no cost.   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PART I: OnTheAir CG Designer    

In this section, we’ll go over OnTheAir CG Designer, starting with the features 
present in the User Interface and then delving into features presented in the Menu 
Bar. 

Most everything you need to create/ modify a project with OnTheAir CG is available 
on the User Interface. 

The User Interface contains five areas (color-coded in the screenshot above, with 
their relative locations):  

• Projects (red, far left) 
• Composition (blue, center) 
• Items (yellow, bottom left-hand corner) and Timeline (purple, bottom) 
• Inspector (green, far right) 

You may Hide (or Show) the Projects, Inspector, or Timeline areas in the Window tab 
of the Menu Bar. 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1. OnTheAir CG Designer User Interface 

1.1. Projects 

The Projects area displays projects that you have previously designed.  You may 
modify an existing project by clicking on it and using the tools presented elsewhere. 

1.2. Composition Area 

The large central panel in the UI is where the project is displayed.  As you add, 
subtract, or otherwise change features, the Composition Area will reflect those 
changes.  Clicking on Items within the Composition Area allows you to modify 
certain features of the item, such as it’s location and it’s dimensions.   

You may change the location by clicking on the Item and pulling where you would 
like it to be displayed.  The dimensions may be changed by clicking on the Item and 
then manipulating the borders by dragging the white squares in the Item’s perimeter.   

Just below the Display area a number of icons used to design your project.  To the 
bottom left is the Tool Bar; each Icon there is used to select a type of Tool to be 
created.  Clicking on a Tool Icon causes it turn blue, indicating that it has been 
selected.  Once an Icon is selected, clicking on the Display creates an Item that can 
be resized and moved about the Display. 

Icons with a dog-ear in the bottom right-hand corner have options that can be 
selected by right clicking on the icon.  Most of these will be discussed more fully in 

the Inspector section. 

Arrow: This sets your cursor to an arrow, allowing you to interact with the 
UI. 

Text:  Clicking this opens a text box wherein you may double-click to add 
text. 

Ticker:  Right-clicking on it gives you the option to create a Ticker with text 
created from a folder, through a Web feed, or entered manually. 
 
Image: This allows you to select a still photo file from Finder. 
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Movie: This allows you to select a video file from folder. 

Clock:  This allows you to create a clock display. Right-clicking on the icon 
allows you to set the display to either an analog or digital clock. 

Shape:  This is used to add a shape to the display. Right clicking on it allows 
you to change the shape to either a rectangle, a rounded rectangle, or an 
ellipse. 

Live:  The last icon allows you to insert a Live video feed. 

Below the center of the display are two arrow keys: 

The left-pointing arrow moves the project to the beginning of its Timeline.  The right-
pointing arrow acts as a Play button for the project. 

Below the bottom right-hand corner of the display are Zoom controls (note that you 
can use the sliding bar or right-click on the Magnifying Glass icon to select a Zoom 
Level from a pop-up menu): 

1.3. Items & Timeline 

The "Items" area displays the Items you have created in your project, and right next 
to them is the timeline area where you can view and modify the timing of each item. 
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1.3.1. Items 

You can enable or disable items using the 
checkboxes on the left.  

The padlock on the right allows you to lock and 
unlock an item. When locked you won’t be able 
to modify it in the Composition area. 

Clicking on an Item highlights it and the 
corresponding Timeline to the right, and opens 
controls on the Inspector Panel specific to that 
particular Item Type. 

The order of the Items corresponds to the 
hierarchy of layering in the project.  Items at the 
top of the list are layered over Items lower on the 

list.  Items can be moved by dragging and dropping them wherever you would like 
them on the list, and hence in the layering hierarchy.  You may also adjust the items’ 
hierarchy by selecting the Item and then clicking Item in the Menu Bar, and from their 
moving the item as you desire. 

1.3.2. Timeline 

Each bar in the Timeline coincides with the Item to its left. 

Above the Timeline bars are times that coincide to the Project’s play time.   

The Timing Bars begin and end at the times selected in the Delay and Hold features 
in the Item’s Timing section.  Items that are Faded in or out have sloping beginnings 
or endings.  The start point of the slope coincides to when the Fade begins, while 
the end point of the slope coincides to when the Fade ends. 

As the project is played, a white Timeline Marker will move along the Timeline, 
showing the current point of time in the project’s playout. 

Below the Timing Bars is a magnifying glass icon.  Clicking on it brings up a sliding 
Zoom bar, allowing you to increase or decrease the spaces between the times.  
Clicking on the 1:1 button returns the spacing to the default setting. 
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1.4. Inspector 

The Inspector panel is the section where the Items in your project are fine-tuned.  
Clicking on an Item in the Items panel brings up a number of features specific to 
each Item Type (discussed below, by Item Type).  Note that by holding your cursor 
over the right-hand corner of each feature section allows you to Hide or Show that 
section.   

There are multiple sections in the Inspector, depending on which Item is selected. 
We will go through these in detail when talking about each item. 
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2. Creating projects 

2.1. Create and delete projects 

You may add a new project by clicking the “+” icon on the bottom left of the panel (or 
by selecting File > New in the Menu Bar), and you may delete a project by clicking on 
the “-“ button.  You may also reopen a project by selecting File > Open… or File > 
Open Recent in the Menu Bar, or by clicking on the “+” icon and selecting “Add 
existing projects.”   

To play out your Project on OnTheAirCG Designer, you must also set up your 
playback settings.  To do so, select OnTheAir CG > Preferences > Playback, and then 
select the Video Output device (any compatible card that is connected to your mac 
will automatically be detected).  You may in the same panel select the Video and 
Audio settings in which you would like to play out your projects. 

Once you have created your project, you must save it by selecting File > Save As (or 
just Save, if you are updating a project and keeping the same file name)> 

Note, as well, that you can control OnTheAir CG Designer, as well as OnTheCG 
Server, via Remote Control by checking the appropriate box in the OnTheAir CG > 
Preferences > General tab. 

2.2. Projects settings 

When you select a project in the project lists, and no item is selected, the inspector 
will only show the Project settings: 
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2.2.1. Project Video Mode 

This setting allows you to select the format of the videos playing on your project.  A 
number of formats, from SD through 4K, are available. 

IMPORTANT Note: If you have set your project to be 1080i59.94, but play it in a 4K 
output for example, the project will not be scaled to the output. It will look small at 

the bottom left of the screen. So choose the same Mode for your project as the your 
playback settings. 

2.2.2. Automatically start stop project with ticker 
 

The Auto Start and Auto Stop feature is used with folder based tickers, and web-
feed tickers. The ideas is that if there is no text to be displayed in the ticker, you 
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don’t want to see the eventual background that was set. These 2 settings will allow 
you to force the whole project to start or stop if there is text crawling or not. 

This feature only works with tickers, so first you will need to add a "Ticker" item to 
your project. Once that is done, click on the popup menu and select which (if there 
are multiple ones) tickers should be running: 

You can select one for the auto start and/or one for the auto stop: 

That way: 
• When the "Ticker Item" is running (there is a text file in the folder and/or content 

in the RSS feed), the whole project will play 
• When the "Ticker Item" is NOT running (there is no text file in the folder and/or 

there is no content in the RSS feed), the whole project will stop playing. When 
there are no text to be displayed, the status of the project in OnTheAir CG 
Server will be "Waiting" 
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2.2.3. Setting up "Smiles" 

Smiles are used to replace a text by an image, exactly as when you type ;-) on some 

smart phones it will be replaced by 😉  . This is very useful in tickers for example, so 
you can replace parts of the ticker by an image. It can be a fixed or animated image 
sequences. 
 

To create a new "Smile": 
• click on the “+” icon 
• select a still image or the first image of an animated sequence tga 

•
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• then to edit the settings of the smile, double click on it, so the following window 

opens: 

• there you can edit 2 main things: 
• if it’s an still image or image sequence (enable the Image sequence option) 
• modify the "Alias". The alias is the text that will be searched for and replaced 

by the image. Make sure that this text is unique. We offer a sample of what 
you could use but you can set it to something easier. 

As soon as that is done, and in a text item (fixed, ticker, …) you type what you have 
set in the "Alias" of the smile, it will be replaced by the image. Again this can be used 
in tickers, but also in fixed text as a quick way to add an image somewhere 
automatically. 

OnTheAir CG 3.2 User Manual - Monday, 19 December 2016



-   -14

OnTheAir CG Designer               

3. Adding and editing items in projects 

Once you have created (or reopened) and set up your project, you can add items to 
it. For that, simply select the project, click on any of the tools at the bottom to create 
a shape, text, still image, video, clock or live item. 

As seen before, depending on the type of item created you will see different kinds of 
information in the Inspector. Geometry and Timing are always shown for all items. 

3.1. Geometry and Timing of items 

3.1.1. Geometry  

You can position and resize items directly in the "Composition" area. But sometimes 
it is easier to work in the inspector. The Geometry section of the inspector allows 
you to fine-tune the dimensions and location of the Item.   

Position:  This allows you to move the Item up and down (on the X and Y axes) in the 
Display via the arrows to the right of the boxes or by left clicking on the box and 
entering a number in the box itself.  The bottom left-hand corner is the 0 point for 
both axes. 

Size:  This allows you to adjust the dimensions (Width and Height) of the Item.  
Checking the “Keep Aspect Ratio” maintains the Width to Height ratio as you adjust 
one or the other.  The 1:1 button reverts the Item to its natural size — if, for example, 
the Item is a 1920 x 1080 video clip and you resized it to 1600 x 910, clicking on the 
button returns the clip size to its original 1920 x 1080. 

Align:  This allows you to adjust the alignment of the Item on the Composition panel.   
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Spacing:  This allows you to adjust the distance between two or more Items.  You 
may hold the “Shift” or “Control” keys to select the Items, and use the arrow keys to 
set the number of pixels that separate them. 

3.1.2. Item’s Timing 

When you have created items, you can add to them start and end transitions, as well 
as set a duration.  

1. In the Timeline 

The easiest way to handle the timing of items is to do it directly in the timeline 
(though you may also do so via the options in the Time tab in the Menu Bar). You can 
simply select an item in the list, then position the playhead where you want and use 
keyboard shortcuts : 

• U = set the start of the "In" transition  
• I = set the end of the "In" transition 
• O = set the start of the "Out" transition 
• P = set the end of the "Out" transition 

You can select multiple items and change all their timing information at once. You 
can also simply drag and drop the different elements directly into the timeline. 

If you want to change the type of transitions, however, you’ll have to do that in the 
inspector. 

2. In the Inspector 

The Timing section allows you to set the time you’d like an Item to present itself, and 
when you’d like it to exit.   
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Here you may also set the Transition effects for the Item. 

Delay:  In the Delay box you may set the time, in seconds measured after the start of 
the Project, in which the Item will be displayed. 

In Transition:  This is where the Transition effects are set up for the start of the Item, 
and includes four items: Type, Option, Duration, and Hold. 

Type: You may choose from four different transition effects: None, Fade, Push, or 
Push and Crop. 

Option: The Push (and Push and Crop) effects allow you to choose the direction 
from which the Item is introduced.  You select that from here. 

Duration: This is where you set the duration of the transition effect. 

Hold: Here you select, in seconds, how long you would like the Item to be present in 
the project.  You may instead set the Item to remain in the project indefinitely by 
checking the “Stay Forever” box. 

Out Transition: This is where Transition effects are set up to end the Item, and are 
set up in the same way as the In Transition effects. 
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3.2. "Publish" items 

Most items (such as Text, images, tickers) have a "Publish" option: 

When this option is enabled, you will be able to modify it through the REST API. You 
need to enable this option if you intend for example to modify a text field from 
OnTheAir Node. But also if you work with the REST API to control OnTheAir CG, only 
the "published" items will be modifiable through the REST API. 
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3.3. Text Items   

The Text Field Item Type includes a Text section: 

Font:  Here you may select the font you would like to use for the text, as well as the 
different varieties of that font (Regular, Bold, Oblique, etc — the choices vary by 
Font). 

Size: Here you set the size of the font you are using.  To the right of that selection is 
a colored line, with which you choose the color of the font.   

Stroke: Here you determine the thickness and color of the Text’s outlines. 

Alignment:  Here you may select the Text’s alignment within the Text box created in 
the Text Tool. 
Text: This box is where you enter whatever text you would like to display. 

Rich Text: Checking this box allows you to use different font sizes and styles in the 
Text. 

Publish as ‘TextField’: Checking this box allows you to use this piece of the Project 
with any application that allows the integration of OnTheAirCG, such as OnTheAir 
Node or OnTheAir Video. See above point 3.2. 
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3.4. Tickers 

There are three different types of Tickers to choose from (Manual, Folder-based, or 
Web Feed), and each has a different feature section available.   

3.4.1. Manual Ticker 

The Font, Size, Stroke, Alignment, Text, Rich Text, and Publish features are as per 

Text Fields, above. 

Speed:  This determines the speed the Ticker moves across the Display, measured 
in pixels per second.   

Type:  This displays the Ticker Type (Manual, Folder-based, or Web-Feed). 

Direction: This allows you change the direction the Ticker enters the display.  Right 
to Left is used for languages where the text is read from left to right, while Left to 
Right is used for languages where the text is read from right to left. 

Play Content Only Once: Checking this box causes the Ticker to cross the display 
only once; by default, it will continually play again once it exits the screen. 
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3.4.2. Folder-Based Ticker: 

The Font, Size, Stroke, Alignment, Speed, Type, Direction, and Content Only Once, 
and Publish features are as per those with the Manual Ticker, above.   

Source: This allows you to set up the path to the folder containing the text you are 
using as a source for the Ticker.   

Separator:  You may enter text in this box to be displayed on a ticker after the text in 
the folder ends and before the folder text starts to play again. 

3.4.3. Web-Feed Ticker 

The Font, Size, Stroke, Alignment, Speed, Type, Direction, Play Content Only 
Once, and Publish features are as per the Folder-Based Ticker, above.  

Feed URL: Here is entered the URL of the RSS feed you would like displayed in the 
Ticker. 

Separator:  You may enter text here to separate the RSS feeds you receive from the 
URL address. 

Sort by:  Here you may select the manner in which the RSS feeds are displayed. 

Refresh:  This feature allows you to refresh the RSS feed at certain increments 

Title: Checking this block displays the RSS feeds’ titles in the Ticker. 
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Description:  Checking this displays the RSS feed’s description (often the body) in 
the Ticker. 

Content: Checking this only shows the RSS feed’s content. 

Play Content Only Once: Once an article has been played on screen once, it won’t 
be shown again, unless you stop and restart the project. 

3.5. Image 

The Image Tool has an Image section, which allows you to select and modify a still 
image (or sequence of still images, to form animation). 

Name:  This is the name of the still file you would like to display.  A folder icon to the 
right of the Name box allows you to select the file from Finder. 
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Location: This is file path for the still image you have selected. 

Preview:  A thumbnail of the still image is displayed here.  To the right of it are the 
the item’s dimensions and arrow icons that allow you to rotate the image.  The up 
arrows flips the image upside down, while the right-facing arrows flips the image 
from right to left. 

Animation:  If the file location contains a series of images and the Image Sequence 
box is checked, the images will all be displayed, in order, at a duration you set up in 
the “Frames/Img.” box. Set for how long each image will be displayed. By default, 
each image is played for the duration of one frame. But you can also set that each 
image is displayed during 2 frames, or longer, and thus playing it for longer.  This 
creates an animated sequence of the images.  If the Loop box is checked, the 
animation will continue to repeat itself. 

Publish:  This works as in the other sections, above. 

3.6. Movie 

The Movie Tool contains a Movie section, wherein you may select the video clip to 
be played in the project, view information on the clip, and set options for the video’s 
playout. 
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Name:  This is the name of the video file you would like to be shown on the Display.  
A folder icon to the right of the Name box allows you to select the file from Finder. 

Location:  This is the path to the folder in which your video clip is located. 

Format:  This is the format of the video file. 

FPS:  This is the frame rate of the video file. 

Duration:  This is the duration of the video file, in Hours:Minutes:Seconds:Frames. 

Size:  This shows the dimensions of the video file. 

Field Order:  By default, the Upper Field is first when playing out Interlaced files. 

Loop:  This allows you to play the video file in a loop. 

Allow Smart Resize:  This allows the Smart Resize feature to be active, which allows 
the high quality resizing of interlaced videos. 

Invert Field Order:  This changes the field order of interlaced video files. 

Premultiply Alpha: This allows you premultiply the alpha. 

Closed Caption:  If the QuickTime video file (.mov) that you play has a Closed 
Captioning CEA-708 track, and it uses the same format as the playback format of 
OnTheAir CG, it will be outputted to the video card through the VANC, the same way 
as with other playout applications. Note that you can only have one movie with the 
option enabled per project, otherwise there will be a conflict between the 2. 

Publish: This works as in the other sections, above. 
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3.7. Clock 

There are two separate Clock Tools available (Digital and Analog), and each 
includes its own feature.   

3.7.1. Digital:  

The Digital Clock Tool has a Text feature section: 

Font, Size, Stroke, Alignment, and Publish all work as per the Text Field Item, 
above.   

Format: These controls allow you to change the format of the clock’s display (for 
example, from a 12 hour AM/PM cycle to a 24 hour cycle).  The Result of the 
formatting shows an example of how the clock will be shown in response to the 
Format chosen. 

3.7.2. Analog 

The Analog Clock Tool has an Image feature section, which operates just like that of 
the Image Tool: 
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3.8. Shape Item 

The Shape Item Tool contains two unique sections: Stroke and Fill.   

The Stroke section allows you to create and modify an outline for the shape you 
have crated.   

Stroke:  This allows you to change the color and thickness of the outline (a thickness 
of 0 leaves no outline). 

Pattern:  This allows you to set a pattern for the outline, i.e. a solid line or dashed 
line.  If you select a dashed or dotted outline, you can modify the layout of the 
dashes (or dots) with the Dash and Gap boxes. 

C. Radius:  This allows you to change the corner radius on a rectangle or rounded 
rectangle shape. 

Fill Type: You may select how you would like the shape to be filled. 

• Color: This fills the shape with a solid color, selected from the colored box to the 
left (or by adjusting the RGBA display to the right of the colored box). 

• Linear Gradient:  This fills the shape with a gradually darkening color from top to 
bottom (or you may click on points on the color bar to add colors to the shape); 
Angle allows you to change the angle of the shape, while Invert flips the shape 180 
degrees. 
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• Radial Gradient:  This fills the shape with a gradually darkening circle that gets 

darker as it radiates from the center (or you may click on points on the color bar to 
add colors to the shape); Angle allows you to change the angle of the shape, while 
Invert reverses the order of color. 

3.9. Live 

The Live Tool contains a Live section that allows you to select a Source for the Live 
Input. 

Source: Here you select the Source of the Live Input.  If the Source is available, a 
green check mark will be displayed.  If not, a red circle will be displayed. 

To use the Live Sources, you must first set up your sources in the Preferences > LIVE 
panel.  There you may add (+) or remove (-) sources.  When you add a source, you 
must select a Video Device Input (any connected devices will be automatically 
detected).  You may change the input device by clicking on the gear icon and 
choosing from the selection shown there. 

FPS, Size, Allow Smart Resize, and Invert Field Order:  See Movie, above. 
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PART 2: OnTheAir CG Server    

OnTheAir CG Server is the application used to play out the projects you have 
created using OnTheAir CG Designer.  

4. Using OnTheAir CG Server 

4.1.  The User Interface 

The User Interface of OnTheAir CG Server is a single panel: 

To add projects to OnTheAir CG Server, simply click the “+” icon in the bottom left 
and select the project you would like to add.  To remove a project, highlight the item 
and click on the “-“ icon.  You may also add or close projects through the Playback 
submenu in the Menu Bar. 

The projects displayed in the panel are shown in the overlay hierarchy; those at the 
top of the list will overlay those below it.  You may move the projects up or down the 
list simply by dragging and dropping them where you would like them displayed. 

A thumbnail of the project is displayed on the left side, and will show a 
wifi icon if the project has been published.  If a red circle is shown on 
the thumbnail, the video source is not available for the project. 

To the right of the thumbnail will be displayed the project’s title.  Below that will be a 
status indicator (Playing, Stopped, or Paused), and below that is the timecode bar for 
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the project.  To the left of the bar will be displayed the length of time that the project 
has played, and to the right is the duration of the project (if any; if the project  is set 
to Stay Forever, the duration display will read —/—/—.   

To the right of the project’s title will be the project’s playback controls (stop, pause, 
and play), below which are boxes to enable Closed Captioning (CC) and put the 
project in a Loop.  Below those controls are the dates and times the project was 
published to OnTheAir CG Server.  The Playback controls are also available in the 
Menu Bar > Playback submenu, or the following hot keys may be used: 

Start/ Pause: Space bar 
Pause: K 
Stop: S 

4.2. Playing Out from OnTheAir CG Server 

To play your projects out from OnTheAir CG Server, you must first set up your 
playback device.  To do so, go to the Menu Bar and select OnTheAir CG Server > 
Preferences > Playback.  There you must select the Video Output Device (any 
compatible video card will automatically be detected and displayed), and then you 
may select the video and audio settings as you desire. 

You may set your OnTheAir CG Server application to resume playback at start up by 
clicking the appropriate box under the General tab in the Menu Bar > Preferences 
submenu. 

4.3. Live Sources 

To playout a Live Video project, you must set up your Live Sources.  To do so, go to 
the Menu Bar and select OnTheAir CG Server > Preferences > Live Sources.  There, 
you may add a Live Source by clicking on the “+” icon in the bottom left corner of the 
panel and then entering the Live Source Name; this name must be identical to that 
indicated in the Project, as set in OnTheAir CG Designer.  You may then select the 
Video Device Input from which the Live Source will be fed (all compatible input 
devices will automatically be detected and displayed).   

You may change the settings of your Live Source by clicking on the gear icon, or you 
may remove the Live Source by highlighting it and clicking on the “-“ icon. 
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